Γενικά για την εταιρία cisco


Λογότυπο της Cisco Systems

Η Cisco Systems, Inc. είναι μια Αμερικάνικη πολυεθνική εταιρία τηλεπικοινωνιών με έδρα το San Jose της Καλιφόρνιας (Silicon Valley). Η οποία σχεδιάζει, κατασκευάζει και πουλάει δικτυακό υλικό, τηλεπικοινωνιακό εξοπλισμό όπως επίσης κι άλλες υπηρεσίες ή προϊόντα υψηλής τεχνολογίας. H cisco επικεντρώνεται κυρίως στους δικτυακούς κλάδους του Internet of Things - ΙοΤ, ασφάλειας δικτύων και διαχείρισης ενέργειας.

Η εταιρία εχει περισσότερους από 70 χιλιάδες υπαλλήλους σε όλο τον κόσμο, και ετήσια έσοδα 40 δισεκατομμυρίων δολαρίων το 2010. Η μετοχή της εισήχθηκε στον δείκτη Dow Jones στις 8 Ιουνίου 2009, και συμπεριλαμβάνεται επίσης στους καταλόγους S&P 500 Index, Russell 1000 Index, NASDAQ 100 Index και Russell 1000 Growth Stock Index. Η cisco ιδρύθηκε τον Δεκέμβρη του 1984 απο δύο επιστήμονες του πανεπιστημίου του Sandford τον Leonard Bosack και Sandy Lerner.

Στις αρχές του 1980 ερευνητικά μέλη του πανεπιστημίου του Standford συμπεριλαμβανομένου και του Leonard Bosack υλοποίησαν μια συσκευή η οποία κατάφερε να διασυνδέσει όλους τους υπολογιστές του πανεπιστημίου δημιουργώντας τυπικά το πρώτο τοπικό δίκτυο - LAN στην ιστορία. Συγκεκριμένα σχεδίασαν το BlueBox μια συσκευή η οποία υποστήριζε την χρήση πολλών πρωτοκόλλων επικοινωνίας. Τυπικά κατάφεραν και υλοποίησαν τον πρώτο δρομολογητή (router). To BlueBox χρησιμοποιούσε ένα λογισμικό που είχε σχεδιαστεί απο τον William Yeager έναν ερευνητή του πανεπιστημίου του Standford.
Στον παρακάτω πίνακα ακολουθούν μερικά απο τα μοντέλα δρομολογητών (routers) και μεταγωγέων (switches) της cisco.



Μοντέλα cisco δρομολογητών (routers)
Μοντέλο URL documentation Εικόνα
cisco 4321 Kλίκ εδώ
cisco 1941 Kλίκ εδώ
cisco 2901 Kλίκ εδώ
cisco 2911 Kλίκ εδώ
cisco 829 Kλίκ εδώ




Μοντέλα cisco μεταγωγέων (switches)
Μοντέλο URL documentation Εικόνα
Cisco IE 1000-4T1T-LM Kλίκ εδώ
Cisco Catalyst 2960X Kλίκ εδώ
Cisco Catalyst 3560G Kλίκ εδώ
Cisco Catalyst 3750V2-48TS Kλίκ εδώ
Cisco Catalyst 3750X-48P-L Kλίκ εδώ
Cisco Catalyst 3850-24U-E Kλίκ εδώ
Cisco Catalyst 4500X-F-32 SFP+ Switch Kλίκ εδώ
Cisco IE-5000-16S12P
Industrial Ethernet Switch
Kλίκ εδώ
Cisco Nexus 56128P Switch Kλίκ εδώ
Cisco Nexus 7700 6-Slot Switch Kλίκ εδώ
Cisco Catalyst C9500-48Y4C-A Switch Kλίκ εδώ


Τα παραπάνω μοντέλα είναι μερικά απο αυτά που έχει βγάλει η cisco στην αγορά. Υπάρχουν επίσης πάρα πολλά μοντέλα που δεν υπάρχουν στους παραπάνω πίνακες. Γενικά στους δύο παραπάνω πίνακες δίνονται τα πιο γνωστά cisco μοντέλα που υπάρχουν στην αγορά αυτήν την στιγμή. Στην ιστοσελίδα της cisco υπάρχουν αναλυτικά όλα τα μοντέλα για δρομολογητές (roters) και για μεταγωγείς (switches).

  1. Documentation της cisco για routers: Κλίκ εδώ
  2. Documentation της cisco για switches: Κλίκ εδώ





Τα πιστοποιητικά της cisco


Τα πιστοποιητικά της cisco είναι πάρα πολλά και χωρίζονται στους εξής κλάδους δικτύων:

  1. Δικτύωσης και δρομολόγησης (Routing and swiching)
  2. Σχεδιασμού δικτύων (Network Design)
  3. Ασύρματων δικτύων (Wireless Networks)
  4. Ασφάλειας δικτύων (Network Security)
  5. IP τηλεφωνίας (Collaboration)
  6. Data center
  7. Υπηρεσίας cloud
  8. Service provider

Γράφημα με τα πιστοποιητικά της cisco


Όπως βλέπουμε κι απο το παραπάνω γράφημα τα πιστοποιητικά της cisco είναι πάρα πολλά. Σε όλα τα πιστοποιητικά cisco υπάρχουν βαθμίδες ανά κλάδο. Το βασικό επίπεδο για να μπορέσει κάποιος να ακολουθήσει έναν κλάδο είναι να αποκτήσει την πιστοποίηση CCENT όπου αποτελεί την πρώτη ενότητα του CCNA. Κάθε κλάδος έχει ένα σύνολλο ύλης πάνω σε βασική θεωρητική και πρακτική γνώση δικτύων όπως επίσης και εξοικείωσης του CLI των cisco συσκευών. Κάθε πιστοποιητικό της cisco έχει ισχύ τριών χρονών.






Τι είναι το cisco packet tracer


Το cisco packet tracer είναι ένα πρόγραμμα προσομοίωσης δικτύων που δημιουργήθηκε απο την πολυεθνική εταιρία cisco. Χρησιμοποιείται κατα κόρον απο την cisco για την απόκτηση πιστοποιητικών της. Είναι ένα πολύ καλό λογισμικό προσομοίωσης δικτύων καθότι μπρούμε να προσθέσουμε όσες δικτυακές συσκευές επιθυμούμε καθώς και να εκτελέσουμε σε αυτό ενέργειες που θα έκανε ένας τεχνικός δικτύων. Σκοπός του packet tracer είναι η εκμάθηση:

  1. Βασικών δικτυακών εννοιών
  2. Επίλυσης δικτυακών σφαλμάτων πάνω σε ενεργό εξοπλισμό της cisco
  3. Εξοικείωσης των cisco εντολών καθώς και του IOS των συσκευών της

Το cisco packet tracer παρέχεται δωρεάν απο την εταιρία με την προϋπόθεση ότι διαθέτουμε έναν λογαρισμό στην διαδικτυακή τους πλατφόρμα εκμάθησης netacad.com. Για την δημιουργία ενός λογαριασμού χρειάζεται ένας πιστοιημένος cisco instructor ή να αρχίσετε σεμινάρια cisco (π.χ. CCNA) που κοστίζουν αρκετά. Παρόλα αυτά παλιότερες εκδόσεις του packet tracer υπάρχουν στο διαδίκτυο και γενικά έχει ανέβει και σε άλλα sites πέραν του netacad.


Welcome screen του packet tracer



Cisco packet tracer έκδοση 7.2






Τα εργαλεία του cisco packet tracer


Στην παραπάνω εικόνα που αποτυπώνεται το γραφικό περιβάλον του packet tracer θα δούμε τέρμα στο αριστερό μέρος του προγράμματος ένα menu με διάφορα λογικά δικτυακά εικονίδια. Απο αυτό το menu μπορούμε να προσθέσουμε δικτυακούς κόμβους. Το άσπρο backgound είναι το workspace οπο εκεί εμφανίζονται οι κόμβοι. Έστω ότι θέλουμε να προσθέσουμε έναν κόμβο θα ακολουθήσουμε την εξής διαδικασία.


Επιλογή switch στο nodes menu του packet tracer



Προσθήκη κόμβου απάνω στο workspace του packet tracer


Αφού το κάνουμε αυτό θα προσθέσει ένα cisco μεταγωγέα (switch) πάνω στο workspace του packet tracer. Σημείωση: οποιοδήποτε αντικείμενο/κόμβος χρειάζεται να προσθέσουμε για να δημιουργήσουμε ένα δίκτυο θα πρέπει να προστεθεί πάνω στο workspace (άσπρος canvas) του packet tracer. Αφού πατήσουμε κλίκ πάνω στο workspace θα μας δημιουργήσει αυτόν τον κόμβο που επιλέξαμε οπως δείχνει και η παρακάτω εικόνα.


Κόμβος που δημιουργήσαμε στο packet tracer


Πατώντας κλίκ πάνω στον κόμβο που δημιουργήθηκε στο workspace του packet tracer θα μας εμφανίσει το παρακάτω παράθυρο που δείχνει η εικόνα.


Αναδυόμενο παράθυρο που εμφανίζεται όταν κάνουμε κλίκ πάνω στον κόμβο


Το παραπάνω παράθυρο μας παρέχει πληροφορίες για τον συγκεκριμένο κόμβο. Το παράθυρο αυτό έχει 4 tabs που από αυτά εμείς θα χρειαστούμε το tab CLI. Ας κάνουμε κλίκ σε αυτό το tab για να δούμε τι θα μας εμφανίσει.


CLI tab του αναδυόμενου παράθυρου του switch που προσθέσαμε


Το πάραπάνω tab μας εμφανίζει το console αυτού του κόμβου. Για να το ρυθμίσουμε θα πρέπει να χρησιμοποιήσουμε εντολές cisco. Όπως καταλαβαίνουμε την ίδια διαδικασία θα πραγματοποιούσαμε αν είχαμε μια πραγματική συσκευή cisco στα χέρια μας. Δηλαδή θα βγάζαμε την συσκευή απο το κουτί θα την βάζαμε στο ρεύμα, θα συνδέαμε ένα ειδικό conole καλώδιο με έναν υπολογιστη και θα αποκτούσαμε πρόσβαση στο switch για να το ρυθμίσουμε.

Ας παραμείνουμε στο menu της προσθήκης κόμβων και να δούμε τι δυνατότητες υπάρχουν. Η παρακάτω εικόνα εξηγεί αναλυτικά τα αντικείμα που μπορούμε να προσθέσουμε απο το nodes menu.


Αντικείμενα που μπορούμε να προσθέσουμε απο το nodes menu


Αυτά βέβαια είναι μερικά απο τα αντικείμενα που διαθέτει το packet tracer. Υπάρχουν επίσης κι άλλα αντικείμενα που δεν αναφέραμε. Εμείς για να υλοποιήσουμε το δίκτυο μας θα χρειαστούμε μόνο δρομολογητές (routers), μεταγωγείς (switches) και τους αντίστοιχους κόμβους του (hosts και servers).






Εισαγωγή στο IOS της cisco: Operation modes


Πρωτού προχωρήσουμε στην υλοποίηση του δικτύου είναι χρήσιμο να εξηγήσουμε την δομή με την οποία λετουργεί το IOS της ciscο. Στο IOS της cisco υπάρχουν 4 modes τα οποία είναι τα εξής:

  1. User EXEC mode >: Είναι το προκαθορισμένο mode και κάθε φορά που αποκτάμε πρόσβαση σε μια cisco συσκευή είναι το πρώτο mode που συναντάμε. Σε αυτό το mode μπορούμε να τρέξουμε περιορισμένες εντολές τύπου ping, traceroute οι οποίες δεν επιρεάζουν τις ρυθμίσεις της συσκευής. Με την εντολή exit ή logout μπορούμε να βγούμε απο user EXEC mode και τυπικά να βγούμε εκτός του CLI καθότι δεν υπάρχει άλλο mode πάνω απο αυτό.

  2. User EXEC mode

    router1>



    Εντολές user EXEC mode
    Εντολή Περιγραφή
    connect Open a terminal connection
    disable Turn off privileged commands
    disconnect Disconnect an existing network connection
    enable Turn on privileged commands
    exit Exit from the EXEC
    logout Exit from the EXEC
    ping Send echo messages
    resume Resume an active network connection
    show Show running system information
    ssh Open a secure shell client connection
    telnet Open a telnet connection
    terminal Set terminal line parameters
    traceroute Trace route to destination

    Όλες οι cisco εντολές σε user EXEC mode


  3. Privileged EXEC mode #: Είναι το δεύτερο mode του IOS της cisco. Για να αποκτήσουμε πρόσβαση σε αυτό απλά γράφουμε σε user EXEC mode την εντολή enable. Με την εντολή enable μπαίνουμε σε privileged EXEC mode. Όπως υποδηλώνει το όνομα αυτό το operation mode επιτρέπει να κάνουμε σημαντικές αλλαγές στο σύστημα μιας cisco συσκευής. Σε αυτό το mode μπορούμε να εκτελέσουμε εντολές όπως disable, erase, write κλπ καθώς κι όλες τις εντολές που υπάρχουν στο user EXEC mode.

  4. Privileged EXEC mode

    router1#



    Εντολές privileged EXEC mode
    Εντολή Περιγραφή
    auto Exec level Automation
    clear Reset functions
    clock Manage the system clock
    configure terminal Enter configuration mode
    connect Open a terminal connection
    copy Copy from one file to another
    debug Debugging functions (see also 'undebug')
    delete Delete a file
    dir List files on a filesystem
    disable Turn off privileged commands
    disconnect Disconnect an existing network connection
    erase Erase a filesystem
    exit Exit from the EXEC
    logout Exit from the EXEC
    mkdir Create new directory
    more Display the contents of a file
    no Disable debugging informations
    ping Send echo messages
    reload Halt and perform a cold restart
    resume Resume an active network connection
    rmdir Remove existing directory
    send Send a message to other tty lines
    setup Run the SETUP command facility
    show Show running system information
    ssh Open a secure shell client connection
    telnet Open a telnet connection
    traceroute Trace route to destination
    undebug Disable debugging functions (see also 'debug')
    vlan Configure VLAN parameters
    write Write running configuration to memory, network, or terminal

    Όλες οι cisco εντολές σε privileged EXEC mode


  5. Global Configure mode (config)#: Είναι το τρίτο mode του IOS της cisco. Σε αυτό το επίπεδο μπορούμε να εφαρμόσουμε καθολικές αλλαγές σε μια cisco συσκευή όπως να αλλάξουμε το hostname κλπ. Απο config mode έχουμε την δυνατότητα να μεταβούμε στα sub modes:
    1. Configure Interface (config-if): Όπου με αυτό το sub mode μπορούμε να ρυθμίσουμε τις διεπαφές ενός router αποδίδοντας IP διεύθυνσεις κλπ
    2. Configure line (config-line): Όπου σε αυτό το sub mode μπορούμε να ρυθμίσουμε ένα virtual terminal line (vty).
    3. Configure router (config-router): Όπου με αυτό το sub mode μπορούμε να εφαρμόσουμε ειδικές ρυθμίσεις υλικού (hardware)

    Global configure mode

    router1(config)#



    Εντολές global configure mode
    Εντολή Περιγραφή
    aaa Authentication, Authorization and Accounting
    access-list Add an access list entry
    banner Define a login banner
    bba-group Configure BBA Group
    boot Modify system boot parameters
    cdp Global CDP configuration subcommands
    class-map Configure Class Map
    clock Configure time-of-day clock
    config-register Define the configuration register
    crypto Encryption module
    default Set a command to its defaults
    do To run exec commands in config mode
    dot11 IEEE 802.11 config commands
    end Exit from configure mode
    exit Exit from configure mode
    flow Global Flow configuration subcommands
    hostname Set system's network name
    interface Select an interface to configure
    ip Global IP configuration subcommands
    ipv6 Global IPv6 configuration commands
    key Key management
    license Configure license features
    line Configure a terminal line
    lldp Global LLDP configuration subcommands
    logging Modify message logging facilities
    login Enable secure login checking
    mac-address-table Configure the MAC address table
    no Negate a command or set its defaults
    ntp Configure NTP
    parser Configure parser
    policy-map Configure QoS Policy Map
    port-channel EtherChannel configuration
    priority-list Build a priority list
    privilege Command privilege parameters
    queue-list Build a custom queue list
    radius-server Modify Radius query parameters
    router Enable a routing process
    secure Secure image and configuration archival commands
    security Infra Security CLIs
    service Modify use of network based services
    snmp-server Modify SNMP engine parameters
    spanning-tree Spanning Tree Subsystem
    tacacs-server Modify TACACS query parameters
    username Establish User Name Authentication
    vpdn Virtual Private Dialup Network
    vpdn-group VPDN group configuration

    Όλες οι cisco εντολές σε global configure mode


Operation modes του cisco IOS







Περιγραφή δικτύου που θα δημιουργήσουμε στο packet tracer


Το δίκτυο που θα φτιάξουμε μέσω packet tracer θα διαθέτει δύο τοπικά δίκτυα LANs. Αυτά τα δύο τοπικά δίκτυα θα συνδέονται πάνω σε έναν δρομολογητή (router) όπου θα αναλαμβάνει την διασύνδεση αυτών των δύο τοπικών δικτύων. Η δρομολόγηση θα είναι στατική και θα πρέπει να αποδοθούν οι κατάλληλες IP διευθύνσεις. Αναλυτικά η τοπολογία αποτυπώνεται στην παρακάτω εικόνα.


Τοπολογία που θα δημιουργήσουμε στο packet tracer


Αναλυτικά το δίκτυο μας έχει τα εξής στοιχεία:

  1. Ένα τοπικό δίκτυο LAN 1 με διεύθυνση δικτύου την 192.68.1.0 με μάσκα υποδικτύου (subnet mask) την 255.255.255.224 ή αλλιώς /27 με μέγιστη χωρητικότητα 30 hosts. Αυτό το τοπικό δίκτυο διαθέτει τα εξής στοιχεία:
    • Δύο hosts
    • Έναν remote access switch server όπου θα μπορούμε να αποκτάμε απομακρυσμένη πρόσβαση στο switch του LAN 1. Προφανώς και θα πρέπει να δημιουργήσουμε VLAN στην αντίστοιχη θύρα port του switch που θα συνδεθεί ο αυτός ο server.
    • Έναν DHCP server ο οποίος θα είναι υπεύθυνος για την απόδοση μιας IP διεύθυνσης στους κόμβους του τοπικού δικτύου
  2. Ένα δεύτερο τοπικό δίκτυο LAN 2 που διαθέτει την διεύθυνση δικτύου 175.168.2.0 με μάσκα υποδικτύου (subnet mask) την 255.255.255.224 ή αλλιώς /27 με μέγιστη χωρητικότητα 30 hosts. Αυτό το τοπικό δίκτυο διαθέτει μόνο έναν content server με IP διεύθυνση 175.168.2.2 ο οποίος ας υποθέσουμε ότι κάνει streaming ένα αρχείο που ζητάνε οι hosts απο το LAN 1.
  3. Και το ενδιάμεσο LAN των δρομολογητών με διεύθυνση δικτύου την 164.16.58.0 μάσκα υποδικτύου (subnet mask) την 255.255.255.252 ή αλλιώς /30 με μέγιστη χωρητικότητα 2 hosts.

Σκοπός μας είναι να εφαρμόσουμε απλές τεχνικές ασφάλειας και να προστατέψουμε το δίκτυο μας απο εξωτερικές επιθέσεις. Στην υλοποίηση αυτη θα δούμε τεχνικές προστασίας ports σε cisco switches καθώς και προστασίας ενός cisco router θέτοντας κωδικό σε κάθε επίπεδο του cisco IOS τους.






Υλοιποίηση δικτύου στο packet tracer


Αφού ανοίξουμε το cisco packet tracer τοποθετούμε τους εξής κόμβους στο canvas workspace του προγράμματος.


Κόμβοι που θα τοποθετήσουμε στο packet tracer


Μεταονομάζουμε επίσης τους κόμβους όπως δείχνει η παραπάνω εικόνα. Για να μεταονομάστε έναν κόμβο απλά πατήστε πάνω στο κείμενο που εμφανίζεται απο κάτω. Αφού τα κάνουμε όλα αυτά πρέπει να συνδέσουμε τους κόμβους μεταξύ τους. Για να το κάνουμε αυτό θα επιλέξουμε απο το nodes menu το εικονίδιο που μοιάζει με κεραυνό και θα επιλέξουμε δύο τύπους καλωδίων copper cross-over και copper straight-through. Από κόμβο σε κόμβο και κόμβο προς διεπαφή router χρησιμοποιούμε straight through κι απο διεπαφή router προς διεπαφή router χρησιμοποιούμε cross-over. Αν το κάνουμε λάθος το δίκτυο δεν θα λειτουργήσει. Να θυμάστε ότι στην διασύνδεση κόμβων όταν έχουμε να κάνουμε μόνο με δρομολογητές δεν χρησιμοποιούμε straight through αλλά cross over. Η σύνδεση θα γίνει ως εξής:

Για το LAN 1:

  1. Straight through | Host 1 (FastEthernet 0/1) → sw_1 (FastEthernet 0/2)
  2. Straight through | Host 2 (FastEthernet 0/1) → sw_1 (FastEthernet 0/3)
  3. Straight through | DHCP Server (FastEthernet 0) → sw_1 (FastEthernet 0/4)
  4. Straight through | Switch remote server (FastEthernet 0) → sw_1 (FastEthernet 0/5)
  5. Straight through | sw_1 (FastEthernet 0/1) → Router_1 (gigabitEthernet 0/0)

Για το LAN 2:

  1. Straight through | Content Server (FastEthernet 0) → sw_2 (FastEthernet 0/2)
  2. Straight through | sw_2 (FastEthernet 0/1) → Router_2 (gigabitEthernet 0/0)

Διασύνδεση routers

  1. Cross Over | Router_1 (gigabitEthernet 0/1) → Router_2 (gigabitEthernet 0/1)

Οι κόμβοι αφού τους συνδέσουμε μεταξύ τους


Για αρχή σκοπός μας είναι το δίκτυο να παίζει και να μην έχουμε κανένα θέμα στην επικοινωνία. Παρατηρούμε απο την παραπάνω εικόνα ότι τα interfaces των δρομολογητών είναι κόκκινα ενώ τα υπόλοιπα είνα πράσσινα. Αυτό συμβαίνει διότι δεν έχουμε ορίσει δρομολόγιση στο δίκτυο και το ένα δίκτυο δεν γνωρίζει το άλλο. Οπότε ξεκινάμε με την ρύθμιση του Router_1.


CLI του Router_1


Κατά την εκκίνηση του CLI θα μας εμφανίσει ένα μήνυμα που λέει "Would you like to enter the initial configuration dialog? [yes/no]:" εμείς πληκτρολογούμε το γράμμα n και πατάμε το κουμπί enter. Μετά ξαναπατάμε άλλη μία το Enter για να μας εμφανησει την κονσόλα (user EXEC mode). Αφού το κάνουμε αυτό πληκτρολογούμε τις παρακάτω εντολές.


Ρυθμίσεις Router 1

Router> enable
Router# configure terminal
Router(config)# hostname Router-LAN-1

Router-LAN-1(config)# interface gigabitethernet 0/0
Router-LAN-1(config-if)# ip address 192.168.1.1 255.255.255.224
Router-LAN-1(config-if)# no shutdown
Router-LAN-1(config-if)# exit

Router-LAN-1(config)# interface gigabitethernet 0/1
Router-LAN-1(config-if)# ip address 164.16.58.1 255.255.255.252
Router-LAN-1(config-if)# no shutdown
Router-LAN-1(config-if)# exit

Router-LAN-1(config)# do write


Αφού ρυθμίσουμε το Router_1 θα πρέπει να ρυθμίσουμε και το Router_2 και να του αποδόσουμε τις σωστές IP διευθύνσεις. Συνεπώς στο CLI του Router_2 γράφουμε τις παρακάτω εντολές.


Ρυθμίσεις Router 2

Router> enable
Router# configure terminal
Router(config)# hostname Router-LAN-2

Router-LAN-2(config)# interface gigabitethernet 0/0
Router-LAN-2(config-if)# ip address 175.168.2.1 255.255.255.224
Router-LAN-2(config-if)# no shutdown
Router-LAN-2(config-if)# exit

Router-LAN-2(config)# interface gigabitethernet 0/1
Router-LAN-2(config-if)# ip address 164.16.58.2 255.255.255.252
Router-LAN-2(config-if)# no shutdown
Router-LAN-2(config-if)# exit

Router-LAN-2(config)# do write


Παρόλα αυτά επικοινωνία δεν θα υπάρχει στο δίκτυο καθότι δεν έχουμε ρυθμίσει την δρομολόγηση. Θα εφαρμόσουμε στατική δρομολόγηση οποτε στο CLI του Router_1 θα γράψουμε την εξής εντολή.


Ρυθμίσεις Router 1

Router-LAN-1> enable
Router-LAN-1# configure terminal
Router-LAN-1(config)# ip route 175.168.2.0 255.255.255.224 164.16.58.2
Router-LAN-1(config)# do write


Αντίστοιχα στο CLI του Router_2 η εντολή θα έχει ως εξής.


Ρυθμίσεις Router 2

Router-LAN-2> enable
Router-LAN-2# configure terminal
Router-LAN-2(config)# ip route 192.168.1.0 255.255.255.224 164.16.58.1
Router-LAN-2(config)# do write


Σε αυτό το σημείο θα ενεργοποιήσουμε τον DHCP server στο LAN 1 έτσι ώστε όλοι οι hosts να παίρνου αυτόματη IP διεύθυνση απο τον ίδιο. Οι ρυθμίσεις του DHCP Server εμφανίζονται στην παρακάτω εικόνα.


Ρυθμίσεις του DHCP Server του LAN 1


Πηγαίνουμε στην καρτέλα services επιλέγουμε DHCP και το radio button on, βάζουμε ως default gateway την IP διεύθυνση 192.168.1.1, start address την 192.168.1.2, μάσκα υποδικτύου (subnet mask) την 255.255.255.224 με maximum number of users το 28 και πατάμε το κουμπί save.


Στην συνέχεια πήγαίνουμε στην καρτέλα Desktop και επιλέγουμε το IP configuration. Σε αυτό το σημείο ορίζουμε την IP διεύθυνση του DHCP server και του δίνουμε την IP διεύθυνση 192.168.1.2 με subnet mask 255.255.255.224 και default gateway την 192.168.1.1 και κλείνουμε το παράθυρο του IP configuration.


Ρυθμίσεις του DHCP Server του LAN 1


Μετέπειτα ανοίγουμε το dummy command prompt του DHCP server και γράφουμε την εντολή ipconfig για να δούμε αν η IP διεύθυνση που βάλαμε όντως μπήκε και μετέπειτα εκτελούμε ένα ping προς το default gateway αν όλα πάνε καλά τότε συνεχίζουμε στην επόμενη διαδικασία που είναι να ρυθίσουμε τους hosts να χρησιμοποιούν DHCP αντί για static IP.


Τα αποτελέσματα απο το command prompt όπου όλα είναι όπως πρέπει


Αφού όλα πήγαν καλά και ο DHCP server επικοινωνεί με το default gateway μπορούμε να ρυθμίσουμε επίσης και τους hosts. Στις παρακάτω εικόνες ακολουθούν οι αντίστοιχες ρυθμίσεις τους.


Ρυθμίσεις IP στον host 1


Ρυθμίσεις IP στον host 2


Ρυθμίσεις IP στον Switch remote server


Σε αυτό το σημειό ρυθμίζουμε τον content server που βρίσκεται στο LAN 2 με μια IP διεύθυνση.


Ρυθμίσεις IP στον content server του LAN 2


Πλέον ήμαστε στο σημείο που μπορούμε να εφαρμόσουμε ping ελέγχους απο το ένα τοπικό δίκτυο στο άλλο. Για τον σκοπό αυτό θα πάρουμε τον Host 2 του LAN 1 ώστε να κάνει ping στον content server του LAN 2.


Ping απο τον host 2 προς τον content server


Ping απο τον content server προς τον host 2


Από τα παραπάνω αποτελέσματα παρατειρούμε ότι το δίκτυο είναι πλήρως λειτουργικό κι ότι όλοι οι hosts επικοινωνούν μεταξύ τους. Οπότε σε αυτό το σημείο μπορούμε να ασφαλίσουμε το δίκτυο μας. Θα ξεκινήσουμε με την εντολή banner motd την όποία θα γράψουμε στους δύο routers και στα δύο switches σε config mode. Με την εντολή banner motd μπορούμε να προσθέσουμε ένα warning message κείμενο σε μια cisco συσκευή η εντολή στο τέλος της ζητάει απο τον χρήστη να δώσει έναν χαρακτήρα όπου θα χρησιμοποιηθεί σαν ένδειξη ότι έχουμε τελειώσει το κείμενο. Εμείς στο τέλος της εντολής θα προσθέσουμε τον χαρακτήρα & (εμπορικό και) συγκεκριμένα η εντολή θα έχει την δομή banner motd &.


Ρυθμίσεις Router 1

Router-LAN-1> enable
Router-LAN-1# configure terminal
Router-LAN-1(config)# banner motd &
Enter TEXT message. End with the character '&'.
################################################

Authorized access please contact with admin

################################################&
Router-LAN-1(config)#do write


Ρυθμίσεις Router 2

Router-LAN-2> enable
Router-LAN-2# configure terminal
Router-LAN-2(config)# banner motd &
Enter TEXT message. End with the character '&'.
################################################

Authorized access please contact with admin

################################################&
Router-LAN-2(config)#do write


Ρυθμίσεις sw_1

Switch> enable
Switch# configure terminal
Switch(config)# hostname sw_lan_1
sw_lan_1(config)# banner motd &
Enter TEXT message. End with the character '&'.
################################################

Authorized access please contact with admin

################################################&
sw_lan_1(config)#do write


Ρυθμίσεις sw_2

Switch> enable
Switch# configure terminal
Switch(config)# hostname sw_lan_2
sw_lan_2(config)# banner motd &
Enter TEXT message. End with the character '&'.
################################################

Authorized access please contact with admin

################################################&
sw_lan_2(config)#do write



Σε αυτό το σημείο θα προσθέσουμε κωδικούς σε όλα τα operation modes των routers και των switches του δικτύου. Για να το κάνουμε αυτό θα γράψουμε τις εξής εντολές:


Ρυθμίσεις Router 1

Router-LAN-1> enable
Router-LAN-1# configure terminal

//Σχόλιο 1: Οι παρακάτω εντολές θέτουν κωδικό στο user EXEC operation mode
Router-LAN-1(config)# line console 0
Router-LAN-1(config-line)# password codebrakes
Router-LAN-1(config-line)# login
Router-LAN-1(config-line)# exit

//Σχόλιο 2: H παρακάτω εντολή θέτει password (με ένα κρυπτογραφημένο επίπεδο ασφάλειας) σε privileged EXEC mode
Router-LAN-1(config)# enable secret codebrakes

//Σχόλιο 3: Οι παρακάτω εντολές θέτουν password όταν κάποιος βάλει ένα console cable από τον router σε έναν υπολογιστή π.χ. laptop και εφαρμόζει επίσης SSH επικοινωνία μεταξύ τους.
Router-LAN-1(config-line)# line vty 0 15
Router-LAN-1(config-line)# password codebrakes
Router-LAN-1(config-line)# login
Router-LAN-1(config-line)# transport input ssh
Router-LAN-1(config-line)# exit

//Σχόλιο 4: Η παρακάτω εντολή κρυπτογραφεί όλα τα passwords. Αν δεν εφαρμόζαμε αυτήν την εντολη εκτελόντας απο privileged EXEC την αντίστοιχη εντολη show run θα εμφάνιζε όλους τους κωδικούς που θέσαμε παραπάνω.
Router-LAN-1(config)# service password-encryption

//Σχόλιο 5: Αποθηκεύουμε τις ρυθμίσεις μας και τρέχουμε την εντολή show run απο privileged EXEC mode
Router-LAN-1(config)# do write
Router-LAN-1(config)# exit
Router-LAN-1# show run


Αφού εφαρμόσουμε τα παραπάνω παρατηρούμε ότι στα αποτελέσματα που μας έβγαλε η εντολή show run όλα τα passwords είναι κρυπτογραφημένα. Τις ίδιες εντολές εφαρμόζουμε σε όλο τον ενεργό εξοπλισμού του δικτύου (router 2 και switches).


Τα αποτελέσματα που μας εμφανίζονται όταν εκτελέσουμε την εντολή show run



Ρυθμίσεις Router 2

Router-LAN-2> enable
Router-LAN-2# configure terminal

//Σχόλιο 1: Οι παρακάτω εντολές θέτουν κωδικό στο user EXEC operation mode
Router-LAN-2(config)# line console 0
Router-LAN-2(config-line)# password codebrakes
Router-LAN-2(config-line)# login
Router-LAN-2(config-line)# exit

//Σχόλιο 2: H παρακάτω εντολή θέτει password (με ένα κρυπτογραφημένο επίπεδο ασφάλειας) σε privileged EXEC mode
Router-LAN-2(config)# enable secret codebrakes

//Σχόλιο 3: Οι παρακάτω εντολές θέτουν password όταν κάποιος βάλει ένα console cable από τον router σε έναν υπολογιστή π.χ. laptop και εφαρμόζει επίσης SSH επικοινωνία μεταξύ τους.
Router-LAN-2(config-line)# line vty 0 15
Router-LAN-2(config-line)# password codebrakes
Router-LAN-2(config-line)# login
Router-LAN-2(config-line)# transport input ssh
Router-LAN-2(config-line)# exit

//Σχόλιο 4: Η παρακάτω εντολή κρυπτογραφεί όλα τα passwords. Αν δεν εφαρμόζαμε αυτήν την εντολη εκτελόντας απο privileged EXEC την αντίστοιχη εντολη show run θα εμφάνιζε όλους τους κωδικούς που θέσαμε παραπάνω.
Router-LAN-2(config)# service password-encryption

//Σχόλιο 5: Αποθηκεύουμε τις ρυθμίσεις μας και τρέχουμε την εντολή show run απο privileged EXEC mode
Router-LAN-2(config)# do write
Router-LAN-2(config)# exit
Router-LAN-2# show run



Ρυθμίσεις Switch LAN 1

sw_lan_1> enable
sw_lan_1# configure terminal

//Σχόλιο 1: Οι παρακάτω εντολές θέτουν κωδικό στο user EXEC operation mode
sw_lan_1(config)# line console 0
sw_lan_1(config-line)# password codebrakes
sw_lan_1(config-line)# login
sw_lan_1(config-line)# exit

//Σχόλιο 2: H παρακάτω εντολή θέτει password (με ένα κρυπτογραφημένο επίπεδο ασφάλειας) σε privileged EXEC mode
sw_lan_1(config)# enable secret codebrakes

//Σχόλιο 3: Οι παρακάτω εντολές θέτουν password όταν κάποιος βάλει ένα console cable από τον router σε έναν υπολογιστή π.χ. laptop και εφαρμόζει επίσης SSH επικοινωνία μεταξύ τους.
sw_lan_1(config-line)# line vty 0 15
sw_lan_1(config-line)# password codebrakes
sw_lan_1(config-line)# login
sw_lan_1(config-line)# transport input ssh
sw_lan_1(config-line)# exit

//Σχόλιο 4: Η παρακάτω εντολή κρυπτογραφεί όλα τα passwords. Αν δεν εφαρμόζαμε αυτήν την εντολη εκτελόντας απο privileged EXEC την αντίστοιχη εντολη show run θα εμφάνιζε όλους τους κωδικούς που θέσαμε παραπάνω.
sw_lan_1(config)# service password-encryption

//Σχόλιο 5: Αποθηκεύουμε τις ρυθμίσεις μας και τρέχουμε την εντολή show run απο privileged EXEC mode
sw_lan_1(config)# do write
sw_lan_1(config)# exit
sw_lan_1# show run



Ρυθμίσεις Switch LAN 2

sw_lan_2> enable
sw_lan_2# configure terminal

//Σχόλιο 1: Οι παρακάτω εντολές θέτουν κωδικό στο user EXEC operation mode
sw_lan_2(config)# line console 0
sw_lan_2(config-line)# password codebrakes
sw_lan_2(config-line)# login
sw_lan_2(config-line)# exit

//Σχόλιο 2: H παρακάτω εντολή θέτει password (με ένα κρυπτογραφημένο επίπεδο ασφάλειας) σε privileged EXEC mode
sw_lan_2(config)# enable secret codebrakes

//Σχόλιο 3: Οι παρακάτω εντολές θέτουν password όταν κάποιος βάλει ένα console cable από τον router σε έναν υπολογιστή π.χ. laptop και εφαρμόζει επίσης SSH επικοινωνία μεταξύ τους.
sw_lan_2(config-line)# line vty 0 15
sw_lan_2(config-line)# password codebrakes
sw_lan_2(config-line)# login
sw_lan_2(config-line)# transport input ssh
sw_lan_2(config-line)# exit

//Σχόλιο 4: Η παρακάτω εντολή κρυπτογραφεί όλα τα passwords. Αν δεν εφαρμόζαμε αυτήν την εντολη εκτελόντας απο privileged EXEC την αντίστοιχη εντολη show run θα εμφάνιζε όλους τους κωδικούς που θέσαμε παραπάνω.
sw_lan_2(config)# service password-encryption

//Σχόλιο 5: Αποθηκεύουμε τις ρυθμίσεις μας και τρέχουμε την εντολή show run απο privileged EXEC mode
sw_lan_2(config)# do write
sw_lan_2(config)# exit
sw_lan_2# show run



Η τελευταία ρύθμιση που θα εφαρμόσουμε θα είναι απάνω στο switch του VLAN 1. Συγκεκριμένα θέλουμε να έχουμε απομακρυσμένη πρόσβαση στο switch και για να το κάνουμε αυτό θα δημιουργήσουμε VLAN πάνω στην θύρα που είναι συνδεδεμένος ο switch remote server. Για να το κάνουμε αυτό θα εφαρμόσουμε σε global config mode τις παρακάτω εντολές.


Ρυθμίσεις Switch LAN 1

############################################

Restricted access please contact with admin
############################################

password:
sw_lan_1> enable
password:
sw_lan_1# configure terminal

//Σχόλιο 1: Δημιουργία ενός VLAN με id 99, ip διεύθυνση 192.168.99.254 και subnet mask την 255.255.255.0
sw_lan_1(config)# interface vlan 99
sw_lan_1(config-line)# ip address 192.168.99.254 255.255.255.0
sw_lan_1(config-line)# no shutdown
sw_lan_1(config-line)# exit

//Σχόλιο 2: Στην διεπαφή που είναι συνδεδεμένος ο switch remote server (fastEthernet 0/5) ανάθεσε σε αυτό το VLAN 99
sw_lan_1(config-line)# interface fastEthernet 0/5
sw_lan_1(config-line)# switchport mode access
sw_lan_1(config-line)# switchport access vlan 99

//Σχόλιο 4: Χρησιμοποίησε μόνο 1 secure mac address
sw_lan_1(config-line)#switchport port-security maximum 1

//Σχόλιο 5: Εnabling sticky learning
sw_lan_1(config-line)#switchport port-security mac-address sticky

//Σχόλιο 6: Αν παραβιαστεί το παραπάνω rule απενεργοποίησε αυτην την θύρα
sw_lan_1(config-line)#switchport port-security violation shutdown

sw_lan_1(config-line)# exit

//Σχόλιο 6: Αποθήκευση ρυθμίσεων
sw_lan_1(config)# do write


Συμπέρασμα

Το cisco packet tracer είναι ένα αρκετά χρήσιμο πρόγραμμα προσομοίωσης δικτύων. Μπορούμε να εφαρμόσουμε πρακτικές που θα έκαναν τεχνικοί δικτύων όπως π.χ. ρύθμιση ενεργού εξοπλισμού, σύνδεση συσκευών μεταξύ τους, εύρεσης σφαλμάτων σε ένα δίκτυο κλπ. Συνεπώς το packet tracer μπορεί να γίνει το κατάλληλο εργαλείο για μελέτη των δικτύων τόσο σε θεωρητικό όσο και σε πρακτικό επίπεδο.


Extras


Μπορείτε να κατεβάσετε την τοπολογία που σχεδιάσαμε πατώντας το παρακάτω κουμπί λήψη τοπολογίας.



Κλίκ για λήψη τοπολογίας     ↓


Τελευταία ενημέρωση: 01/01/2019




Follow us

 ☰